Publicité

Darktable, trucs, astuces, avis, etc...
« Réponse #750 le: 27 Déc, 2019, 11:26:34 am »
Je pense que c'est le ppa NVIDIA qui a installer tous les pilotes en version libre.
Ce que je ne comprends pas c'est qu'il existe des pilotes NVIDIA qui sont libres et non propriétaires ?

Il y a bien une branche libre de pilotes nvidia.

Publicité

*

Hors ligne Caille

Darktable, trucs, astuces, avis, etc...
« Réponse #751 le: 27 Déc, 2019, 11:28:25 am »
Comment faire pour changer de branche. :)

Darktable, trucs, astuces, avis, etc...
« Réponse #752 le: 27 Déc, 2019, 11:32:45 am »
Comment faire pour changer de branche. :)

Déjà désactiver les ppa a mon avis pas indispensables.

Ensuite dans gestionnaire de paquets synaptic aller dans préférence dépots/pilotes additionnels choisir le drive proprio 390 (pas encore testé le 435).

*

Hors ligne Caille

Darktable, trucs, astuces, avis, etc...
« Réponse #753 le: 27 Déc, 2019, 11:50:29 am »
Je viens de supprimer le ppa, maintenant il est indiqué "Le système de paquets est cassé"

Je pense que je vais devoir réinstaller Ubuntu 18.04 pour stabiliser le système et plus rien toucher du tout !

Tu utilise quelle version 18.04 ou 19.10 ?

J'ai fais sudo apt-get install -f mais ça ne change rien.


« Modifié: 27 Déc, 2019, 11:54:46 am par Caille »

Darktable, trucs, astuces, avis, etc...
« Réponse #754 le: 27 Déc, 2019, 12:00:14 pm »
Je viens de supprimer le ppa, maintenant il est indiqué "Le système de paquets est cassé"

Je pense que je vais devoir réinstaller Ubuntu 18.04 pour stabiliser le système et plus rien toucher du tout !

Tu utilise quelle version 18.04 ou 19.10 ?

J'ai fais sudo apt-get install -f mais ça ne change rien.

essaye la ligne de commande suivante en root dans un terminal:
sudo ubuntu-drivers auto-install


c'est parfois miraculeux parfois pas ;)

Je suis toujours en 18.04 je vais changer en mai quand la nouvelle LTS sera sortie.

Je ne change plus tous les 6 mois, pas le temps, je ne change donc que pour les long termes support LTS tous les deux ans.
« Modifié: 27 Déc, 2019, 12:02:38 pm par LViatour »

*

Hors ligne Caille

Darktable, trucs, astuces, avis, etc...
« Réponse #755 le: 27 Déc, 2019, 12:13:06 pm »
essaye la ligne de commande suivante en root dans un terminal:
sudo ubuntu-drivers auto-install
Voici la réponse de ma ligne de commande en capture écran...

Darktable, trucs, astuces, avis, etc...
« Réponse #756 le: 27 Déc, 2019, 12:15:12 pm »
Voici la réponse de ma ligne de commande en capture écran...
essaye avec un espace au lieu du tiret entre auto install

*

Hors ligne Caille

Darktable, trucs, astuces, avis, etc...
« Réponse #757 le: 27 Déc, 2019, 12:30:14 pm »
Rien ne fonctionne, en supprimant le tiret il m'indique une erreur, par contre sans tiret ni espace il ce passe quelque chose.

Laisse tomber, je vais réinstaller... ;)

caille@caille-N76VB:~$ sudo -i
[sudo] Mot de passe de caille :
root@caille-N76VB:~# sudo ubuntu-drivers auto-install
usage: ubuntu-drivers [-h] [--package-list PATH]
                      [--gpgpu [driver[:version][,driver[:version]]]]
                      [--free-only]
                      [<command>]
ubuntu-drivers: error: argument <command>: invalid choice: 'auto-install' (choose from 'list', 'devices', 'install', 'autoinstall', 'debug')
root@caille-N76VB:~# sudo ubuntu drivers auto-install
sudo: ubuntu : commande introuvable
root@caille-N76VB:~# ubuntu-drivers auto install
usage: ubuntu-drivers [-h] [--package-list PATH]
                      [--gpgpu [driver[:version][,driver[:version]]]]
                      [--free-only]
                      [<command>]
ubuntu-drivers: error: argument <command>: invalid choice: 'auto' (choose from 'list', 'devices', 'install', 'autoinstall', 'debug')
root@caille-N76VB:~# sudo ubuntu-drivers auto-purge
usage: ubuntu-drivers [-h] [--package-list PATH]
                      [--gpgpu [driver[:version][,driver[:version]]]]
                      [--free-only]
                      [<command>]
ubuntu-drivers: error: argument <command>: invalid choice: 'auto-purge' (choose from 'list', 'devices', 'install', 'autoinstall', 'debug')
root@caille-N76VB:~# sudo ubuntu-drivers auto-install -h
usage: ubuntu-drivers [-h] [--package-list PATH]
                      [--gpgpu [driver[:version][,driver[:version]]]]
                      [--free-only]
                      [<command>]
ubuntu-drivers: error: argument <command>: invalid choice: 'auto-install' (choose from 'list', 'devices', 'install', 'autoinstall', 'debug')
root@caille-N76VB:~# ubuntu-drivers autoinstall
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Vous pouvez lancer « apt --fix-broken install » pour corriger ces problèmes.
Les paquets suivants contiennent des dépendances non satisfaites :
 libnvidia-ifr1-390 : Dépend: libnvidia-gl-390 mais il n'est pas installé
 libnvidia-ifr1-390:i386 : Dépend: libnvidia-gl-390:i386 mais il n'est pas installé
 nvidia-driver-390 : Dépend: libnvidia-gl-390 (= 390.116-0ubuntu0.18.04.1) mais il n'est pas installé
                     Recommande: libnvidia-gl-390:i386 (= 390.116-0ubuntu0.18.04.1)
E: Dépendances non satisfaites. Essayez « apt --fix-broken install » sans paquet
   (ou indiquez une solution).
root@caille-N76VB:~# apt --fix-broken install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Correction des dépendances... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  lib32gcc1 libc6-i386 libnvidia-common-415
Veuillez utiliser « apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés :
  libnvidia-gl-390 libnvidia-gl-390:i386
Les NOUVEAUX paquets suivants seront installés :
  libnvidia-gl-390 libnvidia-gl-390:i386
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
3 partiellement installés ou enlevés.
Il est nécessaire de prendre 0 o/29,2 Mo dans les archives.
Après cette opération, 147 Mo d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
(Lecture de la base de données... 176175 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libnvidia-gl-390_390.116-0ubuntu0.18.04.1_i386.deb ...
détournement de /usr/lib/i386-linux-gnu/libGL.so.1 en /usr/lib/i386-linux-gnu/libGL.so.1.distrib par nvidia-340
dpkg-divert: erreur: erreur de correspondance sur paquet
  lors de la suppression de « détournement de /usr/lib/i386-linux-gnu/libGL.so.1 par libnvidia-gl-390 »
  « détournement de /usr/lib/i386-linux-gnu/libGL.so.1 en /usr/lib/i386-linux-gnu/libGL.so.1.distrib par nvidia-340 » trouvé
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_i386.deb (--unpack) :
 new libnvidia-gl-390:i386 package pre-installation script subprocess returned error exit status 2
Préparation du dépaquetage de .../libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb ...
détournement de /usr/lib/x86_64-linux-gnu/libGL.so.1 en /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib par nvidia-340
dpkg-divert: erreur: erreur de correspondance sur paquet
  lors de la suppression de « détournement de /usr/lib/x86_64-linux-gnu/libGL.so.1 par libnvidia-gl-390 »
  « détournement de /usr/lib/x86_64-linux-gnu/libGL.so.1 en /usr/lib/x86_64-linux-gnu/libGL.so.1.distrib par nvidia-340 » trouvé
dpkg: erreur de traitement de l'archive /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb (--unpack) :
 new libnvidia-gl-390:amd64 package pre-installation script subprocess returned error exit status 2
Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_i386.deb
 /var/cache/apt/archives/libnvidia-gl-390_390.116-0ubuntu0.18.04.1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@caille-N76VB:~#

Darktable, trucs, astuces, avis, etc...
« Réponse #758 le: 27 Déc, 2019, 18:00:32 pm »
Salut Caille

Tu peux supprimer tous les paquets Nvidia avec la commande suivante :
sudo apt purge nvidia-*
Vu que ça touche aux pilotes dans le noyau, je te conseille de faire un redémarrage. Tu devrais basculer automatiquement sur les pilotes libres, les vrais, appelés Nouveau et non pas Nvidia.

Ensuite tu réinstalles les pilotes propriétaires. Tu devrais avoir accès à la version nvidia-driver-390 avec la Ubuntu 18.04, et à la version nvidia-driver-435 si tu as activé les dépôts 18.04-updates dans ton source.list. En plus de nvidia-settings, n'oublie d'installer le paquet nvidia-prime pour basculer du GPU intel au GPU nvidia.
Vérifie que le paquet libnvidia-compute-XXX s'installe bien en dépendance, c'est ce qui permet d'utiliser OpenCL.

Perso, je tourne avec le même PPA Proprietary GPU Drivers que tu avais, sur les pilotes nvidia-driver-440 et sans aucun souci. Mais ça n'a d'intérêt que si tu dois suivre rapidement les dernières versions du pilotes pour les jeux vidéos. Pour darktable, ce n'est pas indispensable.
« Modifié: 27 Déc, 2019, 18:06:18 pm par Nel »

*

Hors ligne Caille

Darktable, trucs, astuces, avis, etc...
« Réponse #759 le: 27 Déc, 2019, 21:05:54 pm »
Bonsoir Nel et merci !

J'ai fini par réinstaller ce soir, tout va bien.

Cordialement.

*

Hors ligne Caille

Darktable, trucs, astuces, avis, etc...
« Réponse #760 le: 28 Déc, 2019, 15:46:49 pm »
Il semble que plusieurs utilisateurs sont excédé par le retard du ppa de Pascal.
Il ont donc créé un nouveau ppa pour base debian bit:

voilà qui résout ton problème.
sufit de lancer les commandes suivantes:
sudo add-apt-repository ppa: ubuntuhandbook1 / darktable
mise à jour sudo apt-get

https://launchpad.net/~ubuntuhandbook1/+archive/ubuntu/darktable?fbclid=IwAR2Cskx_LDN2leSKS9N5zL15hY1SQ1IxZQUx2F9V16gtEBH9kVNe3Qcb1jQ

Moi je suis passé en version compilé 3.1 avec déjà des nouveautés cette après-midi ;)
Bonjour,

Après avoir réinstallé mon Ubuntu, j'ai fais la manip ci-dessus. ;)
Après j'ai été dans Logiciels Ubuntu, il y avait différentes versions de proposées, dont celle-ci !
C'est bien la version 3.0.0 qui c'est installée
Je n'ai pas osé faire l'installation en ligne de commande de peur que ce soit une autre version qui s'installe ?

sudo apt install darktable
Aurait-elle eu le même effet ?

Cordialement.

*

Hors ligne Caille

Darktable, trucs, astuces, avis, etc...
« Réponse #761 le: 29 Déc, 2019, 13:05:37 pm »
Ensuite tu réinstalles les pilotes propriétaires. Tu devrais avoir accès à la version nvidia-driver-390 avec la Ubuntu 18.04
C'est bien ça, j'ai accès à ce pilote...

...et à la version nvidia-driver-435 si tu as activé les dépôts 18.04-updates dans ton source.list.
Qu'est-ce que c'est que la version 18.04-update ?

En plus de nvidia-settings, n'oublie d'installer le paquet nvidia-prime pour basculer du GPU intel au GPU nvidia.
Vérifie que le paquet libnvidia-compute-XXX s'installe bien en dépendance, c'est ce qui permet d'utiliser OpenCL.
Nvidia-prime c'est installé tout seul avec nvidia-settings lors du passage de la version Ubuntu Libre à la version 390 propriétaire.
Comment je peux vérifier que libnvidia-compute-XXX est installé, actuellement l'OpenCL n'est pas disponible.

Perso, je tourne avec le même PPA Proprietary GPU Drivers que tu avais, sur les pilotes nvidia-driver-440 et sans aucun souci. Mais ça n'a d'intérêt que si tu dois suivre rapidement les dernières versions du pilotes pour les jeux vidéos. Pour darktable, ce n'est pas indispensable.
Avec ce PPA je n'avais que les pilotes Nvidia Libres, voir ci-dessous et le logiciel nvidia-settings ne fonctionnait pas.
Même le pilote depuis nvidia-driver-390 (propriétaire, testé) est passé en nvidia-driver-390 (libre) ?
« Modifié: 29 Déc, 2019, 13:35:04 pm par Caille »

Darktable, trucs, astuces, avis, etc...
« Réponse #762 le: 29 Déc, 2019, 19:25:45 pm »
Qu'est-ce que c'est que la version 18.04-update ?
Je ne sais plus trop où on active cette option. Et j'ai pas trop le temps de faire des recherches ou une install neuve pour voir d'où ça vient. Dans tous les cas, c'est ce qu'indique une recherche dans les dépôts Ubuntu.
https://packages.ubuntu.com/search?suite=all&section=all&arch=any&keywords=nvidia-driver&searchon=names

Comment je peux vérifier que libnvidia-compute-XXX est installé, actuellement l'OpenCL n'est pas disponible.
Normalement il t'informe des dépendances au moment d'installer les pilotes.
En lançant la commande ci-dessous, tu devrais voir si le paquet libnvidia-compute-XXX est installé. Le XXX correspondant à la version installée de tes pilotes.
apt policy libnvidia-compute-*
Pour vérifier qu'OpenCL fonctionne bien avec darktable, il faut lancer la commande suivante. Ça t'indiquera si ça fonctionne ou si ça échoue. Si tu as des "successfully loaded kernel", c'est que tout est ok.
darktable-cltest
Avec ce PPA je n'avais que les pilotes Nvidia Libres, voir ci-dessous et le logiciel nvidia-settings ne fonctionnait pas.
Même le pilote depuis nvidia-driver-390 (propriétaire, testé) est passé en nvidia-driver-390 (libre) ?
Ça je te l'ai déjà dit, le seul pilote libre pour Nvidia c'est le pilote Nouveau. Les autres sont tous des pilotes propriétaires. C'est une connerie qu'il y a eu au moment de récupérer les informations des paquets ou au moment de la traduction en français. Mais de toute façon ça n'a aucune importance, l'information importante c'est la version des pilotes.

Pour nvidia-settings, vérifie que le paquet est bien installé avec
apt policy nvidia-settings
Au pire lance-le par la ligne de commande, il devrait t'indiquer un message d'erreur.

NB: Ah oui, dernière chose. Finalise bien ton installation avec abelthorne sur le forum Ubuntu-fr. Il n'y a aucune raison d'avoir tous ces soucis (OpenCL et nvdia-settings), tu dois faire un truc pas comme il faut, et je ne vois pas ce que ça peut être.
« Modifié: 29 Déc, 2019, 19:29:51 pm par Nel »

*

Hors ligne Caille

Darktable, trucs, astuces, avis, etc...
« Réponse #763 le: 29 Déc, 2019, 20:17:28 pm »
Bonsoir Nel,

Avec cette commande, j'ai la réponse ci-dessous.
darktable-cltestcaille@caille-N76VB:~$ darktable-cltest
0.769587 [opencl_init] opencl related configuration options:
0.769712 [opencl_init]
0.769723 [opencl_init] opencl: 1
0.769731 [opencl_init] opencl_scheduling_profile: 'default'
0.769740 [opencl_init] opencl_library: ''
0.769759 [opencl_init] opencl_memory_requirement: 768
0.769779 [opencl_init] opencl_memory_headroom: 400
0.769796 [opencl_init] opencl_device_priority: '*/!0,*/*/*'
0.769878 [opencl_init] opencl_mandatory_timeout: 200
0.769904 [opencl_init] opencl_size_roundup: 16
0.769921 [opencl_init] opencl_async_pixelpipe: 0
0.769938 [opencl_init] opencl_synch_cache: active module
0.769959 [opencl_init] opencl_number_event_handles: 25
0.769984 [opencl_init] opencl_micro_nap: 1000
0.770004 [opencl_init] opencl_use_pinned_memory: 0
0.770023 [opencl_init] opencl_use_cpu_devices: 0
0.770038 [opencl_init] opencl_avoid_atomics: 0
0.770050 [opencl_init]
0.770568 [opencl_init] could not find opencl runtime library 'libOpenCL'
0.770780 [opencl_init] could not find opencl runtime library 'libOpenCL.so'
0.771026 [opencl_init] could not find opencl runtime library 'libOpenCL.so.1'
0.771047 [opencl_init] no working opencl library found. Continue with opencl disabled
0.771055 [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
0.771061 [opencl_init] initial status of opencl enabled flag is OFF.
caille@caille-N76VB:~$
L'option OpenCL non valable !

Avec cette commande, j'ai la réponse ci-dessous.
apt policy libnvidia-compute-*caille@caille-N76VB:~$ apt policy libnvidia-compute-*
libnvidia-compute-390:
  Installé : 390.116-0ubuntu0.18.04.1
  Candidat : 390.116-0ubuntu0.18.04.1
 Table de version :
 *** 390.116-0ubuntu0.18.04.1 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
        500 http://security.ubuntu.com/ubuntu bionic-security/restricted amd64 Packages
        100 /var/lib/dpkg/status
     390.48-0ubuntu3 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/restricted amd64 Packages
libnvidia-compute-418:
  Installé : (aucun)
  Candidat : 430.50-0ubuntu0.18.04.2
 Table de version :
     430.50-0ubuntu0.18.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
libnvidia-compute-430:
  Installé : (aucun)
  Candidat : 430.50-0ubuntu0.18.04.2
 Table de version :
     430.50-0ubuntu0.18.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
libnvidia-compute-435:
  Installé : (aucun)
  Candidat : 435.21-0ubuntu0.18.04.2
 Table de version :
     435.21-0ubuntu0.18.04.2 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic-updates/restricted amd64 Packages
caille@caille-N76VB:~$

Avec cette commande, j'ai la réponse ci-dessous.
apt policy nvidia-settingscaille@caille-N76VB:~$ apt policy nvidia-settings
nvidia-settings:
  Installé : 390.77-0ubuntu0.18.04.1
  Candidat : 390.77-0ubuntu0.18.04.1
 Table de version :
 *** 390.77-0ubuntu0.18.04.1 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     390.42-0ubuntu1 500
        500 http://fr.archive.ubuntu.com/ubuntu bionic/main amd64 Packages
caille@caille-N76VB:~$

NB: Ah oui, dernière chose. Finalise bien ton installation avec abelthorne sur le forum Ubuntu-fr.
Il n'y a aucune raison d'avoir tous ces soucis (OpenCL et nvdia-settings), tu dois faire un truc pas comme il faut, et je ne vois pas ce que ça peut être.
Tu peux regarder sur les deux captures écrans ci-dessous, que le même driver existe bien en libre et propriétaire.
Utilisation  de NVIDIA driver megapackage depuis nvidia-driver-390 (libre)
Utilisation  de NVIDIA driver megapackage depuis nvidia-driver-390 (propriétaire, testé)

Il y a bien une branche libre de pilotes nvidia.
Donc, si il y a bien une branche libre, il existe aussi une branche propriétaire !
Alors si lors de l'installation c'est le hasard qui joue, moi je ne joue plus.
La capture écran foncé, c'est mon PC aujourd'hui et tout fonctionne bien comme ça !
Pour l'instant je reste au pilote 390 (propriétaire, testé), mais j'aurai aimé comprendre le problème, pourquoi le logiciel de configuration NVIDIA ne fonctionnait pas lorsque la version dite libre était installé ? Il démarrait bien mais avec aucune option, visible sur une capture écran d'un ancien message.

Cordialement.
« Modifié: 29 Déc, 2019, 20:58:13 pm par Caille »

Darktable, trucs, astuces, avis, etc...
« Réponse #764 le: 29 Déc, 2019, 21:58:28 pm »
Ne t'occupes pas de si c'est la version libre ou propriétaire. Je t'ai dit que c'était une erreur d'interprétation dans le logiciel d'installation des pilotes. Dès l'instant que le pilote s'appelle Nvidia, c'est propriétaire. Point. Peu importe ce qu'il y a d'indiqué, il n'y a absolument aucune ambiguïté sur le sujet.
https://fr.wikipedia.org/wiki/Nouveau_(informatique)

D'après tes retours, tu as bien le pilote Nvidia-390 avec la version d'OpenCL adéquat. Mais il ne trouve pas la bibliothèque libOpenCL.so.

À tout hasard, vérifie que tu as bien le chargeur de bibliothèque OpenCL.
apt policy ocl-icd-libopencl1S'il te répond que ce paquet n'est pas installé, alors installe-le.

Comme tu es sur un portable avec 2 cartes graphiques (intel+nvidia), vérifie aussi que tu utilises bien la carte Nvidia. Ouvre nvidia-settings et dans l'onglet PRIME, Nvidia doit être coché. OpenCL ne fonctionne pas avec la carte intel.

Ensuite, tu peux ré-essayer la commande darktable-cltest pour vérifier si OpenCL fonctionne bien avec darktable.

Publicité