Publicité

Bonjour si un utlisateur ayant les mèmes que moi pouvait vérifier que les images exportés sur le PC ont bien les exifs complets , il reconnais la focale, l'ouverture mais pas le nom de l'objectif seule indication :objectif AF-D G VR .
Merci
« Modifié: 18 juin, 2021, 16:49:40 pm par jactib »

Publicité

Bonjour,

J'utilise un Z50 mais pas d'optique Sigma.

Je sais que lorsqu'est apparue la monture Z, certains utilisateurs d'optiques tierces dont Tamron et Sigma ont rencontré des pbs avec certaines d'entre elles.

Pourriez-vous préciser le nom exact de votre objectif car il me semble qu'il y aurait eu différents 17-70 mm chez Sigma ?

Est-ce le 17-70mm 2.8-4 DC MACRO OS HSM | Contemporary pour lequel JC avait rapporté des pb de stabilisation (cf lien);  la version antérieure (non siglé Contemporary) ce qui fait déjà 2 versions possibles, ou un autre ?

https://www.nikonpassion.com/compatibilite-objectifs-tamron-et-sigma-nikon-z/

A+
Z50 plus zooms et focales fixes (monture F et Z)

Tout d'abord merci pour ta réponse mon objectif est bien le : Sigma CONTEMPORARY 17-70 mm f/2.8-4 DC MACRO OS HSM
Les exifs sont bizarres voilà ce qui en sort : la focale, l'ouverture mais pas le nom de l'objectif seule indication :objectif AF-D G VR . hors sur mon logiciel de retouche je ne peut faire les corrections en fonction de la focale car objectif inconnu ! sur le D500 pas de problème . je te joins 2 copies écran l'une avec le D500 et l'autre avec Z50 et FTZ  Désolé je n'arrive pas à les joindre !
« Modifié: 18 juin, 2021, 16:59:18 pm par jactib »

les fichiers joints:
« Modifié: 18 juin, 2021, 17:06:01 pm par jactib »

le suivant :
« Modifié: 18 juin, 2021, 17:05:18 pm par jactib »

Les trois firmwares sont-ils à jour ?
- Z50 ?
- Bague FTZ ?
- Sigma CONTEMPORARY 17-70 mm f/2.8-4 DC MACRO OS HSM ?

Z50 oui Baque non je ne savais pas qu'il y avait une mise à jour! Sigma non
Je vais voir tout ça sur le net , merci

Re,

Pour le Z50, à priori (si le mien est bien à jour..)

Le dernier firmware boitier serait le " C 2.10"
Le dernier firmware pour le FtZ serait le "MA 1.10"

Pour aller plus vite (pour le FtZ) :
https://downloadcenter.nikonimglib.com/fr/download/fw/360.html

A+
Z50 plus zooms et focales fixes (monture F et Z)

Moi aussi Z50 : C 2.10
par contre la bague FTZ n'était pas à jour je m'en occupe et te donnerai des nouvelles ! encore merci :CH

Mise à jour de la bague FTZ effectuée , résultats :
Exifs toujours incomplets pour le sigma 17-70 la mise à jour n'a pa éré faite pour cet objectif !
                                                     nikon  DX AF-S Nikkor 35  F1.8 idem
                                                      nikon AF-S Nikkor 300 F4  E PF ED idem
ces 3 objectifs fonctionnent très bien avec le Z50  seul la marque de l'objectif est absente !
le Tamron 90 F2,8  macro lui ne fonctionne pas mise au point manuelle obligatoire !
C'est quand mème bizarre que ceux ci ne posaient pas de problèmes  sur mon ancien D7100 puis sur le D500  dommage je trouve que ce Z50 à de belles qualités je l'ai  acheté comme 2° boitier et je pense que Nikon aurai pu s'arranger pour que la plupart de  ses objectifs soient parfaitement compatibles . Pour les sigma et tamron il faut passer par leurs docks respectifs bien compliquer tout ça ! Je vais contacter Nikon pour leur signaler le problème ?
Merci en tout cas à ceux qui m'ont répondu
Jacques                               
                                             

« Modifié: 20 juin, 2021, 10:23:39 am par jactib »

Salut jactib,

Tu regardes les EXIF avec darktable qui utilise libexiv2 pour les extraire.
libexiv2 est une purge monumentale pour récupérer le vrai nom de l'objectif.
libexiv2 est une bibliothèque qui a quand même été conçue précisément dans ce but précis, et se plante lamentablement sur tout un tas d'objectifs.  ::)

Je te conseille plutôt d'utiliser exiftool qui a toujours donné la vraie référence de l'objectif.
exiftool -LensID NomDuFichier.NEF
Si tu veux corriger ce problème d'affichage, tu peux aller jeter un oeil à ce post que j'ai fait sur darktable.fr :
https://forums.darktable.fr/showthread.php?tid=5392&pid=44844#pid44844
Tout y est décrit, mais il faut savoir manipuler la ligne de commande et les fichiers de config pour pouvoir l'adapter à ton problème.

 Merci je vais essayer ça ! j'avais déjà fait une manip du genre pour le nikon 200-500 avec le D500 (https://forums.darktable.fr/showthread.php?tid=5252)  bien des problèmes avec exiv2 !

Bon pas moyen j'ai essayé avec ta méthode , j'avais essayé en modifiant le "slr-sigma.xml" sans résultats je pense que les  infos ne passent pas bien avec la bague FTZ ! nikon propose une bague pour utiliser les objectifs en monture F mais c'est pas au point ! à vrai dire c'est surtout pour le 17-70 les corrections sont intéressantes pour le 300 et le 35 qui sont des focales fixes je fais les corrections directement avec Darktable  . En tout cas merci .

Est-ce qu'au moins exiftool te donne la bonne réponse ?
Si tu modifies la base de données lensfun et que l'intitulé ne correspond pas exactement, ça ne fonctionnera pas. Je te conseille vivement de laisser la base de donnée lensfun non modifiée, de sorte à pouvoir faire les mises à jour des corrections d'objectifs sans casser tes corrections manuelles à chaque fois.

Sinon le plus simple, tu choisis manuellement l'objectif Sigma et tu l'enregistres en tant que pré-réglages. Ce qui te permet de le rappeler en 1 clic.

C'est ce que je fait , pour le 35 et le 300 nikon j'applique un préréglage , pour le sigma je suis obligé de mettre un réglage à chaque fois comme c'est un zoom ! un peu contraignant mais je survivrai !
Pour les exiftools la réponse n'est toujours pas bonne ! problème de transmission via la bague je pense !
Bonne soirée

Publicité